Roku Requirements

These are the current technical requirements for this brand of device:

Supported Model(s):

All Models running RokuOS 8.1 or Above

Min. OS Version:

RokuOS 8.1+

Supported Audio:

Digital 5.1

Was this answer helpful?